SVN 1.7 breaks Python packaging

Forget my problems with Emacs and SVN 1.7.  A much worse problem is that my Python package distributions are breaking because neither setuptools nor distribute groks the new working copy format introduced in SVN 1.7, and so not all files which are actually under version control get included in the output of dist commands (without using an explicit manifest).  So, I’m forced to downgrade to SVN 1.6, which is alright by me.  First I had to uninstall from Cygwin SVN and all packages that depend on it.  Then I installed the SlikSVN Win64 distribution of SVN 1.6.  And, finally, I had to trash all my SVN 1.7 working copies (no way to downgrade those) and re-checkout everything.

Advertisements